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1 Introduction

The document details the use of Eclipse which can be used with FTDI FT51A and FT90x MCU
products to test and develop applications and software.

1.1 Overview

Eclipse is a free open source Integrated Development Environment (IDE) which is used to provide
a cross platform development and debugging environment. It features an integrated project
manager, code editor, build configurator and debugger.

FTDI also offer an alternative IDE from MikroElektronika which is not covered in this document.
Please refer to the MikroElektronika website for further information.

1.2 Scope
The scope of this document is to
e briefly discuss installation and FTDI MCU specific configuration
e show how to create or import projects
e show how to build projects
e show how to program and debug

e provide tips and tricks and troubleshooting help
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2 Eclipse IDE Installation and Configuration

The toolchain installers give an option to install a version of Eclipse as part of the installation
process. However you can also use your own version.

The latest Eclipse IDE is recommended. At the time of writing, Luna is the current version and this
is referenced in this document, which includes screenshots.

The Eclipse IDE can be downloaded from the Eclipse website:

https://www.eclipse.org/downloads/

Select ‘Eclipse IDE for C/C++ Developers’ and choose the relevant windows download (32 Bit or
64 Bit). Download the file (.zip), extract and run ‘eclipse.exe’ found in the top level folder. Note
that the eclipse IDE download is not an ‘installer’ program. The Eclipse IDE program is contained
within the .zip file. A user can create a shortcut on their desktop to run Eclipse IDE for ease of
access.

This also means that multiple versions of Eclipse can exist on the same PC.

2.1 Java Development Kit

To be able to run the Eclipse IDE, this additional program is also required to be installed on your
PC. Eclipse tells you if this is not installed.

The Java Developer Kit (JDK) can be found on Oracle’s website:

http://www.oracle.com/technetwork/java/javase/downloads/index-jsp-138363.html

Click on download, accept the license agreement, select the platform required and follow the
installer’s instructions.

2.2 Eclipse Workspaces

The default workspace location is decided when the program is first executed as shown in Figure
2.1.

= Workspace Launcher =

Select a workspace

Eclipse stores your projects in a folder called a workspace,
Choose a workspace folder to use for this session,

Workspace: C\Users\Username\workspace - Browse...

Use this as the default and do not ask again

OK l | Cancel

Figure 2.1 Eclipse Workspace Launcher

Avoid directories with spaces in the names which can cause issues when it comes to build,
program and debug.

Project settings are contained within the specific project, so multiple projects for multiple MCUs
can reside in the same workspace.
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However, you can create multiple workspaces if required, for example separate workspaces for
FTDI FT51A and FT90x MCUs. This should be done before creating or importing projects. Once
Eclipse is started, Select File > Switch Workspace - Other and select the desired location on the
PC.

2.3 Eclipse IDE Startup

When eclipse is started for the first time, the welcome screen is shown in Figure 2.2. This allows
the user to learn about Eclipse to get an overview of the features, try out samples and access
tutorials.

& C/C++ - Eclipse =@ = |
File Edit Source Refactor Navigate Search Project Run Window Help

= @ Welcome 52

7]

()

Welcome to the Eclipse IDE for C/C++

Developers
( j Overview Tutorials
‘m\) Get an overview of the features N o through tutorials
@ Samples . /\_ What's New
Try out the samples V Find out what is new

Figure 2.2 Initial Eclipse Startup

When the user is finished with the initial welcome screen, click on the restore icon as shown in
Figure 2.3 to start the normal Eclipse IDE environment. Note that the welcome screen can be
accessed at any point from the Help > Welcome menu.
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& C/C++ - Eclipse
File Edit Source Refactor Mavigate

E Welcome 23

T Retore

o

Figure 2.3 Restore Eclipse Icon

Figure 2.4 shows the Project Explorer, editor and tool icons, although there is not much shown
until a project is created or imported.

& C/C++ - Eclipse

= B |
File Edit Source Refactor Navigate Sesrch Project Run Window Help
e O R e O @ e O Bt QNI e e s quck access | 5 | [EIGE)
[ Project Explorer 52 BEg|le =18 =8 [%o0. % @M. BT. = O

-

An outline is not available,

[£] problems 52 Tasks Console perties ® =08
0 items

Description Resource Path Location Type

Figure 2.4 Standard Eclipse IDE Screen
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3 MCU Specific Installation Requirements

Please see the following App Notes for details on additional tools required to use the Eclipse IDE
with FTDI MCUs:

e FT51A (8 bit MCU): AN_352 FT51 Installation Guide
e FT90x (32 bit MCU): AN 325 FT900 Tool Chain Installation Guide

In summary the following installation options are available for each FTDI MCU product:

3.1 FT51A

1. Install the Software Development Kit (SDK) from FTDI: installs tools, libraries, sample
code, documentation and source code. Options available:

e FT51A Programmers Guide
e FT51A Firmware Libraries & Examples
e FT51A Tools

=  External Tools

e SDCC

e GnuWin32 Make & CoreUtils
e Java JRE

e Eclipse

= Install FT51A Tools in SDCC bin directory
= FT51A Tools Source Code
e FT51A Accessories
= FT51A Plugins for Eclipse
» libusb-win32 and WinUSB Driver for FT51A DFU

3.2 FT90x

1. Install the FT90x Toolchain Setup Executable. This installs tools, libraries, example code
and documentation. Options available:

e Eclipse IDE for FT90x

e FT90x Driver Library

e FT90x Example Applications

e External Utilities
e GnuWin32 Make & CoreUtils
e Python

e Update PATH variable

e Create icons on desktop

Install Eclipse plugins via Help > Install New software menu if you are using your own version of
Eclipse.
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4 Eclipse Projects

There are a couple of options for Eclipse projects which are detailed in this section:
e Importing Example Projects

e Creating New Projects

4.1 Importing Example Code

FTDI provide example software projects with full source code in order to help users learn about our
products and on-chip modules and how to use them.

Within Eclipse, perform the following actions:
e File > Import Projects > General - Existing Projects into Workspace
e Browse to the location of the example code provided as part of the FTDI installer:
o FT51A: C:\Users\Username\Documents\FTDI\FT51A_SDK\Version\examples
o FT90x: C:\Users\Username\Documents\FTDI\FT90x\Examples

e The user can decide to select the ‘Copy projects into workspace’ option or to use the
existing location of the code.

The project should now appear in ‘Project Manager’.

& Import B &
Import Projects Ml
Select a directory to search for existing Eclipse projects. / ,n":
-

@ Select root directory:  CUsers), YDocuments\FTOLLV - Browse...

Select archive file: Browse

Projects:

| AN_354_FT51A_Standalone_Demo_Application (C:\Users\ Select All

Deselect All
Refresh

4 n F

Options

Search for nested projects
| Copy projects into workspace

Hide projects that already exist in the workspace
Waorking sets

Add project to working sets

I/?:' < Back lext = [ Finish ] | Cancel

Figure 4.1 Import Project
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4.2 Creating New Projects

The process for creating a new project is detailed in this section.

4.2.1 FT51A
Within Eclipse, perform the following actions:
e File > New > C Project
e Enter Project Name. Note: avoid names with spaces.

e In Project Type, select ‘Empty Project’ or ‘Basic Project for SDCC’. Note that other options
exist.

e In Toolchains, select ‘'SDCC Tool Chain’
The project should now appear in ‘Project Manager’.

r & C Project =] =7

C Project —

Project name must be specified

Project name:

Use default location

C\Users\David.Paterson\Documents\Products\ MCLUN32bith T Browse
default

Project type: Toolchains:
- = GNU Autotools Cross GCC
| = Executable FTDIchip FT90x GCC

® Empty Project Microsoft Visual C++

@® Hello World ANSI C Project MinGW GCC

@ Basic Project for SDCC SOCC Tool Chain

@ USB DFU Project for FT51

@ USB HID Keyboard Project for FT51
- (= Shared Library
- [z= Static Library
- = Makefile project

« 1 b

Show project types and toolchains only if they are supported on the platform

I/?} < Back Mext > Finish Cancel

Figure 4.2 FT51A New Project

4.2.2 FT90x
Within Eclipse, perform the following actions:
e File > New > C Project
e Enter Project Name. Note: avoid names with spaces.
e In Project Type, select ‘Empty Project’.
e In Toolchains, select ‘FTDIchip FT90x GCC’

The project should now appear in ‘Project Manager’.

10

Product Page
Document Feedback Copyright © 2015 Future Technology Devices International Limited


http://www.ftdichip.com/FTProducts.htm
mailto:docufeedback@ftdichip.com?subject=Document%20Feedback:%20TN_160%20Version%201.0

7 Technical Note
FTDI TN_160 Eclipse Projects

AN Ch|p Version 1.0

Document Reference No.: FT_001175 Clearance No.: FTDI# 475

=

5 Adding Files to Projects

To add files to a project there are a few methods detailed here.

5.1 Add New Files

Right-click on the project within Project Explorer and select ‘New’ then select Source File or Header
File for example.

5.2 Add Existing files

Drag existing files from windows explorer into the project in Eclipse. Note that Eclipse gives the
option to either copy the file to the current project or link the file to the project from the existing
location.

The user can also manage files at windows explorer level, then right-click on project within Project
Explorer and select Refresh (F5).

5.3 Adding Include Directories

In order to add include directories like libraries, right-click on Project within Project Explorer and
select Properties. Navigate to C/C++ General »> Paths and Symbols. Note the options available
which should be selected depending on your needs.

B | Add directory path 2

Directory:
SAMN_354_FT51A_Standalone_Demo_Application/inc

| Add to all configurations Mool

| Add to all languages

J| i = a workspace path Waorkspace...

il

File systemn...

OK ] | Cancel

Figure 5.1 Add Directory Path
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6 Building Projects

Building a project is the process to create an executable which can be programmed onto the MCU.
Additional outputs are debugging and file mapping or memory information.

Firstly, you should select the type of project that you would like to build. This can be done through
‘Project > Build Configurations > Set Active’ menu.

The options are:
e Debug
e Release

Unique directories with executable are created for each option.

There are a few options available to build a project:
¢ Right-click on the project within Project Explorer and select ‘Build Project’
e Select the project in Project Explorer. Click the build icon G%

e Press CTRL + B to build all projects in Project Manager
The output of the build process will appear in the ‘Console’ window.

Note that you should save files before building. There is no warning about unsaved files. Unsaved
files have '*’ before the filename within the editor.

Sometimes a project clean may be required. This can be done by:

e Right-clicking on the project within Project Explorer and select ‘Clean Project’

12
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7 Programming devices

The process for programming FT51A and FT90x devices are different. See the sub-sections below
for further information.

7.1 FT51A

FTDI provide an external tool as part of the SDK to program the device, and this is run from within
Eclipse. This needs to be setup initially, but can be run via a button thereafter.

e Select Run > External Tools > External Tools Configuration.

e Click on Program, then click the ‘New Launch Configuration’ icon
e Enter the details as shown in Figure 7.1 as an example.

e Click Apply and Run.

& External Tools Configurations =
Create, manage, and run configurations @
Run a program |
" |
= 4,
= X | = 5P T Mame: Program FT51A MTP
type filter text D Main " Refresh | |oh Build % Environment | [C] Commeon
4 "é If'rngram Location:
@, Program FT51A MTP "
Isers\, \Documents\FTDTVFTS1A_SDKNL0.0tools\bin'ftS1prg.exe
Browse Workspace... | | Browse File System... | | Variables...
Working Directory:
Browse Workspace... | | Browse File System... | | Variables...
Arguments:
-g "${project_loch\${config_name:${project_name}\8{project_namehihx"
Variables...
Mote: Enclose an argument centaining spaces using double-quotes ("),
Filter matched 2 of 2 iterns = =
'/?:‘ [ Run ] | Close

Figure 7.1 FT51A External Tools Configuration
The console window shows the progress. A successful program should be like:
Available devices are:
Description: "FT230X Basic UART". Serial Number: DBXOPYIY.
Opened debugger port: FT230X Basic UART
Programming ShadowRAM... Done.
Committing...Done.

Running.
‘b

Note that there are other options available like programming Shadow RAM, and the FT51A can be
programmed over USB via DFU (Device Firmware Upgrade). Please see AN 352
FT51 Installation Guide for further information.

The next programming action can be performed by the T button.
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7.2 FT90x

FTDI provide an external tool as part of the SDK to program the device, and this is run from within
Eclipse. This needs to be setup initially, but can be run via a button thereafter.

e Select Run > External Tools > External Tools Configuration.

e Click on Program, then click the ‘New Launch Configuration’ icon
e Enter the details as shown in Figure 7.2 as an example.

e Click Apply and Run.

& External Tools Configurations o]
Create, manage, and run configurations @
Run a program -=.-|
=
= ET—
EIEED Name:  FT90x Program MTP
typefilter text [=] Main ™" Refresh | [} Build | i Envirenment | =] Common
4 @, Program Location:

(G FT90x Program MTP

@ FI90x Program MTP File C:\Program Files (<&6\FTDIVFT90x Toolchain Teolchain\programmerdistiFT300Prog.exe

[ Browse Warkspace.. | | Browse File System...| | Variables.. |
Working Directory:
[ Browse Workspace...| [ Browse File system...| | Variables... |
Arguments:
-f "S{project lochS({config name:S{project name}\${project nameLbin” -0 v
Variables.

Note: Enclose an argument containing spaces using double-guotes (*).

Filter matched 3 of 3 items.

® -

Figure 7.2 FT900 External Tool Configuration

The console window shows the progress. A successful program should be like:

Initializing...

Flash programming progress:

&

Note that there is an external GUI version available which can be used to program the FT90x
device. The shortcut is created on your desktop and is available in Eclipse ‘FTDI Utilities” menu as
part of the installation. Please see AN 325 FT900 Tool Chain Installation Guide for further
information.

The next programming action can be performed by the T button.
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8 Debug

The Eclipse IDE provides a highly configurable debug environment as shown in Figure 8.1

including:
e Debug control buttons (step, run, halt, stop, etc)
e Source Code and project files
e Variables and breakpoints
¢ Memory windows (requires range setup)

Debug Control Buttons

= Debug fANj54,rr51.a,s¢anda\une,nemo,.apprimiun/dyggs(npse

slE =

File Edit Source Refactor MNavigate Search ect Run  Window Help
i ARG W S

H-r0-Q-®mE Y- i GO Quick Access | {5 | B C/Cr+ [ Debug |
45 Debug 52 [i% ¥ = B (= Variables % %@ |Fiet =15
4 [E] AN_354_FT51A_Standalone_Dema_Application Debug [C/C++ Application] Name Type Value -
4 {2 AN 354_FT51A Standslone Demao_Application.cdh [il] = line2 char 30] O024e
P :
4 ot Thread [L] (Suspended: Breakpoint] . (@ heartRateSamples int [10] 0x026¢ A
_E mein0 at demo testci 131 0x2ca3 (9 heartRateSampleCount char 000 E
»el gdb 9= lastBeatTime int 0
£9- thresh char 0:32
©9: pulse i 0:00
©9: heartRate char
6= trachSamnlec char il 2 .
i Function
Variables
Breakpoint '
emo_test.c = Outline
and current 4 % = 0 = outine =0
PC l u%n::{ EFES:?T%E; :19;' = FALSE; 2 A RN o ¥ -
uints_t heartRateCalculating = ; & stdlibh o
uintd_t fsrforce = @; ® stdinth
o stdioh E
device_initialise(); % string.h
) N u fisLh
omux_setup()s o sl sk
usb_setup(); B registers\fiS1_registersh
N =0 registers\ftS1_aio_registers.h
latency_timer_initialise(); B registers\fiS1_dio_registersh
o %1 registers\ftS1_spi_registers.h
12C_master_initialise(); 81 registers\ftSL_iocell_registersh
// Reset the LCD display =0 registers\ftS1_iomux_registers.h
Source PO = @xf8; // Set reset line of LCD high for Sms &l registers\ft51_pwm _registersh
timer %1 fi51_general_configh
Code me -general cortig
ggllea(gg,t{mezgi . ‘o = fi51 interruptsh
= @xfa; // Clear reset line of L i R —
) % f51 usbh -
0 Memory 12 mroog e [ (EE) % v = o
Meniters 25 3 % [0:800000 : 05800000 <Hex> 52 gk New Renderings...
@ 0x400000 Address @ - 3 4-7 s -8 c-F -
& 0xB00000 - Memory
00800000 1CLIFFFF  FFFFFFB2  1CO1FFFF :
& 0000000 Window
00800010 FFFFFFO2  1CFAFFFF  FFFFFF2  1DC2FFFF
00800020 FFFFFFO2  1E2SFFFF  FFFFFF2  1ESBFFFF =
FFFFFF32  FRFFFFFF FFFFFF32  FFFFFFFF
FFFFFF32  FRFFFFFF FFFFFF32  FFFFFFFF
FFFFFF32  FRFFFFFF FFFFFF32  FFFFFFFF
90300060 FFFFFF32  FFFFFFFF  FFFFFFO2  1EEEFFFF <
Witable Smartlnsert | 1131:25

Figure 8.1 Debug Environment

The project must be compiled before debug can be setup.

Note: switch between Development and Debug perspectives

& | B

at top right hand corner
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8.1 FT51A

FTDI provide a tool called ‘ft51gdb.exe’ which is executed through Eclipse. This is based on the
SDCC debugger but implements an “MI” interface similar to GDB.

Unique debug configurations are required to be set up for each project as shown in Figure 8.2.

e Select Run > Debug Configurations.

e Click on ‘C/C++ Application” and then click the ‘New Launch Configuration’ icon
e Choose the .cdb file for your project.

e Modify the Debugger tab with ‘ft51gdb.exe’.

e Click Apply and Run.

The next debugging action can be performed by the {f" ~ button.

Please see AN 352 FT51 Installation Guide for further information.

£ Debug Configuraticns 2
Create, manage, and run configurations %L
EIEE

Mame: AN_354_FT51A_Standalone_Dema_Application Debug

type filter text B Main ™_69- Arguments | B Environment | %% Debugger| i~ Source| = Common

[€] C/C++ Application )

[£] AN_354_FT51A_Standalone_Dema_Application Debug ||| </C++ Application:

[2] Program FT90x MTP Debug/AN 354 FTS1A Standalone Demo_Application.cdb
[E] C/Co+ Atach to Application

el Variables... | [Search Project..] [ Browse.. |
[] C/C++ Postmartem Debugger

[E] C/C++ Remote Application Project:

B> Launch Group AN_354_FT51A_Standalone_Demo_Application Browse...

Build (if required) before launching
Build configuration: Debug
7| Select configuration using 'C/C++ Application’

Enable auto build Disable auto build

® Use workspace settings Configure Workspace Settings...

< m 3

Using GDB (DSF) Create Process Launcher - Select other... Appl

Filter matched 7 of 7 items

@

Figure 8.2 FT51A Debug Configuration
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8.2 FT90x

FT90x provides a GDB based debugger (ft32-elf-gdb) as part of the installer which is executed

through Eclipse.

‘FT90x GDB Bridge’ desktop shortcut or Eclipse ‘FTDI Utilities’ menu is provided for converting GDB
commands into the debugger module commands. This must be run before debug can start.

Unique debug configurations are required to be set up for each project as shown in Figure 8.3.

e Select Run > Debug Configurations.

e Click on C/C++ Remote Application” and then click the ‘New Launch Configuration’ icon

e Choose the .elf file for your project.

e Select ‘GDB (DSF) Manual Remote Debugging Launcher’
e Modify the Debugger tab with ‘ft32-elf-gdb.exe’.

e Set the Connection to Port number 9998.

e Click Apply and Run.

The next debugging action can be performed by the ﬁ; * button.

Please see AN 325 FT900 Tool Chain Installation Guide for further information.

2 Debug Configurations

e,

Create, manage, and run configurations

IR
type filter text B Main
4 [E] C/C++ Application

[E] AN_354_FT51A Standalone Demo_Application Debug
[2] Program FT90x MTP
[T] C/C++ Attach to Application
[E] C/C++ Postmortem Debugger
4 [E] C/C++ Remote Application Project:
[€] FT900 Example Applications Debug
¥ Launch Group

Fl I

Filter matched & of 8 items

a
@

Name: FT900 Example Applications Debug
%5 Debugger | & Source| [T] Common

C/Cr+ Application:
UART/uart_examplel. eff

FT900 Example Applications Browse..
Build (if required) before launching
Build configuration: Default
] Select configuration using 'C/C++ Application’
Enzble auto build Disable auto build
@ Use workspace settings Configure Workspace Settings.
Using GDB (DSF) Manual Remote Debugging Launcher - Select other.. App
Debug Close

&

Variables.. | [search Project...] [ Browse.. |

Figure 8.3 FT90x Debug Configuration
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9 Tips and Tricks

This section details some tips and tricks when using Eclipse IDE.

9.1 Editor

Warning / Error symbols appear on Left Hand Side of text editor which provides quick view to
newly typed code for example. Mouse over for details eg ‘symbol could not be resolved’ and
missing ';’.

To find where a function resides, select a function, right-click and select ‘Open Declaration’ and the
editor should take you to that function code even if it exists in another file.

The yellow arrows provide ease of navigation though code LR .

9.2 Build Automatically

The Workbench will automatically perform incremental builds of resources modified since the last
build. Whenever a resource is modified, another incremental build occurs. Select the option via:

Project - Build Automatically
To avoid all projects building before programming FT51A memory, uncheck the following option:

Window - Preferences - Run/Debug - Launching - Build (if required) before launching

9.3 Debug

There are 3 hardware breakpoints available on FTDI MCU products. When initiating debug, a
temporary breakpoint is set at the start of the main function.

When in the debug window, right-click on the blue bar at left hand side of the source code window
and select Toggle breakpoint to set/reset breakpoints.

There is also a Breakpoint window visible via Window - Show View - Breakpoints.

To restart debug quickly, Right-click on the debug session in the debug tab and select ‘Terminate
and Relaunch’.

Note that you must kill a debug session before device can be programmed as the same hardware
is used for both program and debug.

9.4 Eclipse Specifics

A wide range of Eclipse plug-ins are available. See Help > Eclipse Marketplace. For example, a
‘terminal’ plug-in is available to allow external commands to be run within Eclipse, particularly
useful when running FT90x debug.

CTRL + SHIFT + L gives a list of all Eclipse shortcuts which can be configured via Windows >
Preferences > General > Keys.

Quick Access box or CTRL + 3 allows users to quickly go to views, perspectives and more.

See Help - Tips and Tricks for more!
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10 Troubleshooting

10.1 Access is Denied

If you sometimes see the following error in Eclipse when trying to build projects, it is caused by
AVG or similar antivirus software because a batch file is run in a kind of sandbox, in order to
protect the PC:

make: *** Access is denied.
. Stop.
make: *** Waiting for unfinished jobs....

The solution is to retry, or temporarily disable antivirus software, or try adding an exception to the
antivirus software (exclipse.exe).

10.2 Breakpoints

There are only 3 breakpoints available on FT51A and FT90x. If you try to set more than 3
breakpoints in Eclipse, the program may become unstable and debugging is no longer allowed.

There are no warnings that more breakpoints have been used than are available.

To overcome this you must terminate and restart the debugger. You may also have to disconnect
and reconnect the debugger.

10.3 Java Error

If you see the following error after launching Eclipse, this is caused by a different Java and Oracle
Java Development Kit (JDK/JRE) versions:

Java was started but returned exit code=13

This can happen after updating your PC's Java (java.com) version. For example, installed Java
Version 8 Update 25 from java.com, but current Oracle JDK/JRE version was Java SE Development
Kit 7.

The solution is to download Java SE Development Kit from Oracle to match the Java.com version.

10.4 Build Error

If you see errors during build of a project that relies on library code or other include code/files,
Eclipse may not know where the files exist. For example:

../kbd.c:9:18: fatal error: ft51.h: No such file or directory
compilation terminated.

make: *** [kbd.rel] Error 1

make: Target 'main-build' not remade because of errors.

To add include files and directories, see section ‘5.3 Adding Include Directories’.

10.5 Viewing Definitions

In Eclipse, right click on a function or variable name and select ‘Open Declaration’ to see the
source or definition. If you see an error saying that it cannot be found, then you may need to add
the include directory. See section ‘5.3 Adding Include Directories’.

Alternatively try Project > C/C++ Index - Rebuild, and then Project > C/C++ Index - Freshen
all files to try to get Eclipse to recognize the libraries.
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10.6 Directory Names

When trying to debug your application code and receive an error like the following:
Error in final launch sequence
Failed to execute MI command:

-environment-cd "C:/Users/username/Documents/MCU
Stuff/eclipse/workspace/FT51A UART"

Error message from debugger back end:
Cannot CD to directory
Cannot CD to directory
This is because there is a space in the directory name (*"MCU Stuff”).

Always choose a workspace, or project directory, with a continuous directory name.

10.7 Environment Variables
When installing the tools, you need to add some data to the PATH environment variables.
These tips should ensure no issues:

1. Ensure that there are no spaces before or after the ';' for each entry in the environment
variable

2. Close all windows file and internet explorer windows for the changes to take effect. If in
doubt, restart the PC.

10.8 FT51A Build Error 1

If you see the following error when trying to build an FT51A project:
make -k all
Cannot run program "make": Launching failed
Error: Program "make" not found in PATH
Then you need to make sure the GnuWin32 bin directory path the environment variable.

Note that you need to close all windows explorer applications (file and internet) for any
environment variable changes to come into effect.

10.9 FT51A Build Error 2

If you see the following error when trying to build an FT51A project:
kK k
make all
make: *** No rule to make target “all'. Stop.

This can be due to incorrect importing of projects into Eclipse.

If you want to import the example projects, you must do the following:
File --> Import --> General --> Existing Projects into Workspace

Do not choose C/C++ --> Existing Code as a Makefile Project as FT51A projects do not use
makefiles.

Note that if you incorrectly import a project, this changes the project settings, which means that it
may become corrupt. The solution is to use a fresh version of the project that needs to be
imported.
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Also, when you right-click on the project and the ‘Build Project’ is greyed out, then you must first
left-click on the project, then right-click. Alternatively use the build icon.

10.10 FT51A Programming Error 1

If you see the following error:
ERROR: no filename specified

Then either the external programmer has not been setup correctly, or you simply need to click on
the project in Eclipse before running the external programmer.

Other things to try:
1. Put quotation marks around the file/location data:
-s -g "${project_loc}\${config_name:${project_name}}\${project_name}.ihx"
2. Use an absolute path (for testing purposes):
-s -g "C:\Users\Username\Documents\Products\MCU\8bit\FT51A_UART\Debug\FT51A_UART.ihx"

3. Check that the file physically exists at the location specified in the External Build Tool
configuration:

"C:\Users\Username\Documents\FTDI\FT51A_SDK\Version\tools\bin\ft51prg.exe"

10.11 FT51A Programming Error 2

When trying to program the FT51A device and see the following error:
Available devices are:
Description: "FT230X Basic UART". Serial Number: DBXOPYIY

Cannot open debugger

Then you need to change the Arguments in the Run-->External Tools-->External Tools
Configuration in Eclipse to include the debugger

Original argument:
-g "${project_loc}\${config_name:${project_name}}\${project_name}.ihx"
New argument:

-p "FT230X Basic UART" -g
"${project_loc}\${config_name:${project_name}}\${project_name}.ihx"
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Tel: +1 (503) 547 0988
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Appendix A - References

Document References

Eclipse: https://eclipse.org/

MikroElektronika: http://www.mikroe.com/

http://www.ftdichip.com/Support/Documents/AppNotes.htm
AN_352 FT51_Installation_Guide
AN_325 FT900_Tool_Chain_Installation_Guide

Acronyms and Abbreviations

Terms Description
usB Universal Serial Bus
IDE Integrated Development Environment
MCU Micro Controller Unit

PC Personal Computer

JDK Java Developer Kit

SDCC Small Device C Compiler
PATH Environment Variable
SDK Software Development Kit
DFU Device Firmware Upgrade
GDB GNU Debugger

C/C++ Programming Language
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